Short sharing of a strange case.
We’ve written a small manifest in order to distribute some python scripts. You can find the reference here: https://medium.com/metrosystemsro/new-ground-automatic-increase-of-kafka-lvm-on-gcp-311633b0816c
When you try to run it on Ubuntu 14.04, there is this very strange error:
Error: Failed to apply catalog: [nil, nil, nil, nil, nil, nil]
The cause for this is as follows:
Python 3.4.3 (default, Nov 12 2018, 22:25:49)
[GCC 4.8.4] on linux (and I believe this is the default max version on trusty)
In order to install the dependencies, you need python3-pip, so a short search returns following options:
apt search python3-pip Sorting... Done Full Text Search... Done python3-pip/trusty-updates,now 1.5.4-1ubuntu4 all [installed] alternative Python package installer - Python 3 version of the package python3-pipeline/trusty 0.1.3-3 all iterator pipelines for Python 3
If we want to list all the installed modules with pip3 list, guess what, it’s not working:
Traceback (most recent call last): File "/usr/bin/pip3", line 5, in from pkg_resources import load_entry_point File "/usr/local/lib/python3.4/dist-packages/pkg_resources/init.py", line 93, in raise RuntimeError("Python 3.5 or later is required") RuntimeError: Python 3.5 or later is required
So, main conclusion is that it’s not related to puppet, just the incompatibility between version for this old distribution.